04 Dakota trans issues - DODGE DAKOTA FORUM - FORUM AND OWNERS CLUB!
DODGE DAKOTA FORUM - FORUM AND OWNERS CLUB!  

Go Back   DODGE DAKOTA FORUM - FORUM AND OWNERS CLUB! > DODGE DAKOTA FORUM - Help Zone - Dodge Dakota Problems, Complaints, and Solutions > 2ND Generation Dodge Dakota: 1997 - 2004 > Driveline
Dodge Ram Dodge Durango Dodge Nitro Jeep
Diesel Forums!
Dodge Ram Forum Dodge Durango Forum Dodge Nitro Forum Jeep Forum
Dodge Challenger Dodge Charger Chrysler 300 Dodge Magnum
Dodge Caliber
Dodge Challenger Forum Dodge Charger Forum Chrysler 300 Forum Dodge Magnum Forum


Notices

Driveline Transmissions, Differentials, Axles, Bearings, etc. This forum covers the entire driveline from the Transmission to the wheel bearings!

Reply
 
Thread Tools
  #1  
Old 07-28-2015, 05:27 AM
gkat gkat is offline
Dodge Dakota Forum Newcomer
 
Join Date: Jul 2015
Posts: 2
Vehicle: 2004 Dodge Dakota
Trim Level: sport
Color: silver
Engine: 2004-2010 - 4.7
Rep Power: 0
Rep:10
gkat is on a distinguished road
Default 04 Dakota trans issues

I have been pulling my hair out trying to figure this out.....
Check engine light comes on and the tranny doesn't shift into overdrive.
I disconnect the battery to reset things and it works great for a few days. I am thinking solenoid.....
Am I thinking right?
__________________
DakotaForumz.com | Dodge Dakota Forum | Dodge Dakota Forums | Dodge Dakota Performance | Dodge Dakota Accessories
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-03-2015, 02:36 AM
Kevindepot Kevindepot is offline
Dodge Dakota Forum Newcomer
 
Join Date: Jun 2015
Location: Northern Ca.
Posts: 5
Vehicle: 2000 Dakota 4x4
Trim Level: Sport
Color: Red
Engine: 2000-2004 - 4.7 L (287 cu in) PowerTech V8, 230 hp (170 kW)
Rep Power: 0
Rep:10
Kevindepot is on a distinguished road
Default

Check the speed sensor on the tail shaft housing, drivers side. The sensor is around $20 all you need is a 10mm wrench to change it. Takes about 5 minutes.
__________________
DakotaForumz.com | Dodge Dakota Forum | Dodge Dakota Forums | Dodge Dakota Performance | Dodge Dakota Accessories
Reply With Quote Quick reply to this message
  #3  
Old 05-30-2016, 01:52 PM
Ubie Ubie is offline
Dodge Dakota Forum Newcomer
 
Join Date: Apr 2016
Location: Yon
Posts: 9
Vehicle: 2004 Dodge Dakota
Trim Level: SLT Plus
Color: Black
Engine: 2000-2004 - 4.7 L (287 cu in) PowerTech V8, 230 hp (170 kW)
Rep Power: 0
Rep:10
Ubie is on a distinguished road
Default

Sorry to revive a dead thread, but I'm having the same issue. Have the 545RE, CEL came on steady and won't shift beyond 3rd. Also getting a P0700 code. Unfortunately, the wife is driving the truck about 2000mi from me...

***update***
Sorry, I have more details now:
Wife started up the truck this morning, CEL came on coming out of the parking lot and won't shift in to 4/5th (1-3 is fine).
Stopped about an hour later (yeah, I know...) and ran the codes and got P0700 and when it started back up still has CEL and will now shift ok to 4/5th. Should I be looking at the solenoid or speed sensor as a start, or somewhere else?
__________________
DakotaForumz.com | Dodge Dakota Forum | Dodge Dakota Forums | Dodge Dakota Performance | Dodge Dakota Accessories

Last edited by Ubie; 05-30-2016 at 04:10 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #4  
Old 07-20-2016, 12:31 AM
Ubie Ubie is offline
Dodge Dakota Forum Newcomer
 
Join Date: Apr 2016
Location: Yon
Posts: 9
Vehicle: 2004 Dodge Dakota
Trim Level: SLT Plus
Color: Black
Engine: 2000-2004 - 4.7 L (287 cu in) PowerTech V8, 230 hp (170 kW)
Rep Power: 0
Rep:10
Ubie is on a distinguished road
Default

Quote:
Originally Posted by Ubie View Post
Sorry to revive a dead thread, but I'm having the same issue. Have the 545RE, CEL came on steady and won't shift beyond 3rd. Also getting a P0700 code. Unfortunately, the wife is driving the truck about 2000mi from me...

***update***
Sorry, I have more details now:
Wife started up the truck this morning, CEL came on coming out of the parking lot and won't shift in to 4/5th (1-3 is fine).
Stopped about an hour later (yeah, I know...) and ran the codes and got P0700 and when it started back up still has CEL and will now shift ok to 4/5th. Should I be looking at the solenoid or speed sensor as a start, or somewhere else?

2nd Update:
Apparently my wife simply isn't allowed to drive the truck. I've put 1000+ miles on it since I last cleared the code and nothing. It's been perfect. Both times the damn thing has tripped is when she has been driving, so... no more truck for the wife
__________________
DakotaForumz.com | Dodge Dakota Forum | Dodge Dakota Forums | Dodge Dakota Performance | Dodge Dakota Accessories
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the DODGE DAKOTA FORUM - FORUM AND OWNERS CLUB! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address

Please enter a valid email address for yourself.

Note: If your email address requires someone to click a link before they can send you email, DO NOT REGISTER WITH IT as no one is here to click the link and you will never get your activation email!
We have banned MANY Free email providers.
If you get notice that your email address is banned when you try to sign up, it is because its been banned due to spammers using the provider, or too many members bouncing emails we send back to us via the free provider! If this happens to you, you will need to use a different email. If you do not provide a valid email address you will not receive your activation email. We recommend that you register with an email address which is attached to your ISP! Not a free service! We have found that using free accounts causes you to not receive your registration email. In any case, you should add DakotaForumZ.com to your spam filter whether using a free account or your ISP account. If you bounce email to us, you will have your account deleted and your IP address banned!

Email Address:
Vehicle
Enter the model year and make of your vehicle! (I.E. 2000 Dodge Dakota)
Engine
Please select your engine so that members will be better able to answer questions you ask on the forum! This shows up on your profile page!
Insurance
Please select your insurance company (Optional)
Color
What color is your vehicle?
Trim Level
What trim level did you purchase?

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Advertisement



All times are GMT. The time now is 10:08 PM.


Powered by vBulletin® Version 3.8.10 Beta 2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © VerticalScope Inc. All rights reserved.