Dakota Forumz banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My friend has a 2005 dodge dakota that started driving rough about three weeks ago so he parked it and when he went to start it again four days later, it made it to the end of his parking lot and stalled. it started again and made it into a parking space and hasn't moved since. i have gotten it to start up but only with starter fluid. I have gotten it to run for almost thirty seconds with starter fluid periodically spraying into the intake and while doing that he said it was running better than ever

what i have done so far is replaced the mass air flow sensor, the dodge dakota's have a different name for it, i don't know what it is because i've never really worked on one until now. we made sure there is fuel pressure to the fuel rails, he recently put on a new fuel pump himself. i wanted to test the spark plugs but i didn't get around to it, we tested the battery and even put a battery pack on it while cranking just to be sure.

what i'm thinking is it could be dirty injectors, or something to do with the spark plugs or coils. I was hoping to get someone else's opinion on the situation because like i mentioned, i'm not very familiar with dodge dakota's.
 

·
Registered
Joined
·
1,199 Posts
I think you're confusing the MAP sensor with a MAF sensor; they're not the same.

How MUCH pressure is there on the fuel rails? If it's not adequate (I THINK about 35PSI but am not sure - check the factory service manual!) then you won't get run. I had that problem on my 2000 Malibu, so it's not a "Dodge" problem, but a "EFI" problem.

RwP
 
1 - 4 of 4 Posts
Top