Dakota Forumz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hey everybody, Names Jamon.

I got on the forum in hopes any of you reading might be able to point some things out to me to help me get this beast on the road, running smoother.

I've got a misfire, coming from Cylinder #6.
I've got almost what I want to say feels like engine drag?
And huge power loss over all.

At any stop, it takes some blocks to get up and go, and you'll hear nothing but the sound of a piston "Thump" the entire run.
It won't stay in gear, basically shifts early.
For a minute there before replacing the Throttle position sensor,
In slow speeds, such as pulling into the driveway, the engine would die or try to die while engaging the power steering at a sharp angle.

Now I've replaced a whole list of basic things, including throttle position sensor, Plugs and Cables, Cleaned distributor, Cleaned IAC, And Replaced timing chain, (The timing chain is way in there, got the water pump While I was at it.)

To this day, it drags some ass from any stop.
Any amount of pedal pressure insures the backfire, and some thunking noises.
Idles perfectly fine, even does Reverse Okay.
But in drive, the moment you put it Under "Load", it starts chuggin, and powers gone.

Any advice helps.
Been at this for too long with next to no improvement.

Thanks!

(P.S. I've also got three broken bolts hangin' around the exhaust manifold-to exhaust pipe, Able to hear exhaust gases rushing out from the moment ignitions engaged and the thing starts turnin'.)
 

·
Banned
Joined
·
2,418 Posts
Hello and welcome!

Good to have you with us, I hope you enjoy the board! :)
I moved your other thread to a better sub forum where hopefully the right people will see it and have some help for you! I can't help you with this unfortunately.
 

·
Registered
Joined
·
1,567 Posts
Welcome to the Z Family from Germantown, Maryland!
Glad you decided to join us.
 
1 - 5 of 5 Posts
Top