Dakota Forumz banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Sorry in advance for such a long story. I have a 2007 quad cab with a v8 4.7. I bought it 4 years ago, about 2 years ago the check engine light came on and I noticed that it started to make a popping sound that sound is random there is no pattern to it. This didn't happen everyday. Then after few weeks while driving the engine would shake like it was going to die this started to happen everyday I thought maybe it wasn't getting gas so a friend of mine hooked up a scanner and it gave a code for the egr valve. I replaced that and the truck was fine for a few days then it started again. Then about a week later the weather got cold (45 & colder) winter set in and it didn't do it anymore. Spring came the outside temps got back up above 50 and the problems started again. I took it to a full service shop and had the plugs replaced and of course the check engine light would not come on and it wouldn't "act up" for the shop. The day I went to pay for the tune up while I was paying (the truck was running) it started making the popping sound but no check engine light. The mechanic hooked up his scanner it gave no code but did say random misfire in I think #3, he moved the injector around to see if the error would follow and it did not. This lasted all last summer stopped again in the winter and now this spring has started again. I've been given several opinions on what the problem is. I'm considering replacing the coils or the injectors but don't want to just throw money at it.
I've noticed that when the outside temp is above 50 if I drive to work about a 25minute drive on the highway it's fine same with the drive home. If I don't let the truck sit for a few hours then the problem will start up. Once the engine is warm the more I drive it the worse the problem gets.

Has anyone else had this issue before?
 
1 - 1 of 1 Posts
Top