Dakota Forumz banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've got a '90 Dakota with a 3.9 I ran a diagnostic on it and it came up with a bad/ going bad Crankshaft Position Sensor. Now I've talked to others and looked all over the internet. I have the new part in hand but CAN NOT find the CPS any where on the engine. What I know is mine should be located by the bell housing right behind the driver side Head. I also know that in 92 it was moved to behind the pass side head under the EGR tube. I have been searching for it for a total of about 4 hours now. I've looked everywhere in those areas and others and can not find it. I can't even feel it, feeling for both the mounting bolts or the wiring harness. Any help or pictures would be greatly appreciated!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Appreciate the help but that's the same thing I've seen before. That is where it's supposed to be after '92. Now pre '92 is supposed to be in the same spot but right behind the driver side head. Only thing... no hole, mounting bolts, bracket or wiring harness to be found. Starting to wonder if this was an engine that they tried changing around for a year but went back to. I don't know. It's the oddest damn thing. Worked on a LOT of vehicles but never came across something like this.
 

·
Registered
Joined
·
115 Posts
humm... honestly idk then man ive never delt with a 90s dak only my 04 and the 97 5.9l is the only mopar engines ive delt with... maby see if the dealer could point you in the right direction or something im sure that something like that just showing you where it is they would do for free
 
1 - 5 of 5 Posts
Top