Dakota Forumz banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
couple weeks ago my Truck was overheating when it was idle, on the freeway it would cool back down to regular temp and it started overheating and leaking so i bought a new water pump, new thermostat radiator hose and a new temperature sensor for it installed all of them and it still says its overheating no smoke is showing or any leakage anybody know what it is?
 

·
Registered
2003 RT (5.9)
Joined
·
699 Posts
What year/what engine?

Did you change the fan clutch when you changed the pump? That is always a good idea. It sort of sounds like maybe your fan isn't doing enough at idle, but the flow of air at highway speeds is sufficient.

That's just a guess.
 

·
Registered
2003 RT (5.9)
Joined
·
699 Posts
. . . also, change your rad cap if you haven't already done so. A relatively cheap but neglected part that can adversely affect your cooling system if not functioning correctly.
 

·
Registered
Joined
·
24 Posts
DO NOT, I repeat, DO NOT try to hold the fan as you start the engine. I have had customers tell me that they will just try to hold the fan and if it’s bad they will be able to hold it still while starting. I re-educated them very quickly. I started working on cars when I was 11 yrs old. I am now 60. No hands or fingers lost!
 

·
Registered
Joined
·
764 Posts
I edited my post, I meant to check the fan resistance while the engine is not running.

I didn't think anyone would mess with a fan on a running engine, but anything is possible. Thanks for adding that 1987.
 
1 - 6 of 6 Posts
Top