Dakota Forumz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all,
I'm a relatively new owner of a 2004 V8 4x4 Dakota. I've noticed recently with the cold weather in BC that the Screen is getting fogged up if i'm wearing any damp clothes (as expected) but when I turn the dial to the screen defrost mode nothing really happens, I'm still getting hot air blowing mainly out of the footwells. There is a very small amount of air coming out the defrost vent, and it clears the screen slightly (bottom half, more on passenger side) but I'm sure it should be working better than it is.

I've read that a lot of people have had the opposite problem (hot air only coming out of the defroster vent) but can't seem to find anything like mine. I have a feeling its a vent door issue but I just wanted to check here first to see if anyone has had the same issue and fixed it themselves or if they have any thoughts on what I could do.

Thanks!
 

·
Registered
Joined
·
5 Posts
same deal no defrost

I have the same deal on my 04 2wd 3.7 no defrost air blows from dash vents and floor board only will switch between the 2 but not to defrost could use a little help with this one as well
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Right! Good news and bad news. I finally got round to climbing into the drivers side footwell and under the dash. I found the problem quite quickly. The bar that goes between the servo and up to the vent door is twisting itself as the servo rotates and popping the pin out of the groove it moves in. This in turn caused the motor to stop turning before it could force the vent door open.

I couldn't for the life of me figure out why it was twisting, that's a task for another day. (only so much time I can spend upside down and contorted in the there). In the meantime to fix the defrosting issue, I disconnected the bar at the very top and rotated the vent door so that the defroster is now always open.

Although this isn't the final fix, it means I can now clear my windshield extremely quickly.

I'll be sure to come and update this when I get it all completely working.
 

·
Registered
Joined
·
5 Posts
I have an 04 Dakota sxt base model mine is doing the EXACT same thing doing a heater core replacement going to clean everything real good and reassemble and bench test mine was full of dirt dust ect I bet replacement parts arm lever ect will be a little tough to find
 

·
Registered
Joined
·
1 Posts
Right! Good news and bad news. I finally got round to climbing into the drivers side footwell and under the dash. I found the problem quite quickly. The bar that goes between the servo and up to the vent door is twisting itself as the servo rotates and popping the pin out of the groove it moves in. This in turn caused the motor to stop turning before it could force the vent door open.

I couldn't for the life of me figure out why it was twisting, that's a task for another day. (only so much time I can spend upside down and contorted in the there). In the meantime to fix the defrosting issue, I disconnected the bar at the very top and rotated the vent door so that the defroster is now always open.

Although this isn't the final fix, it means I can now clear my windshield extremely quickly.

I'll be sure to come and update this when I get it all completely working.
did you ever get this figured out? I’m having the same issue.
 
1 - 5 of 5 Posts
Top