Dakota Forumz banner
1 - 20 of 40 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 · (Edited)
Hello from Utah. I recently picked up a 01 Dakota quad cab 4wd. 4.7 V8 , 165,000 miles.
Tell me all about em. Any things to look out for, sensors I should be replacing soon ?
I'll be towing a 6x10 V-nose cargo trailer with it on our longer vaca trips.
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 · (Edited)
Thanks.
The plans for it are to keep it stock but it needs upper ball joints and tires.
It had a cold air intake and exhaust already.
Last week I picked up a shell for $125 to put on it. Sent it off for a color match since it was blue.
Also I had a police push bar from a 2015 Durango I was going to put on my jeep but..... decided to put it on the truck.
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #10 ·
Some great info here. Thanks guys.
It came with new oil pan gasket, heater control, and 02 sensors that haven't been installed yet.
The trans fluid looks new. I noticed it had the resistor done already. I'll look for that tube.

Here's a few pics with the police push bar installed, grill painted black and the shell color matched. Also tested it pulling the trailer.
Automotive tire Vehicle Tire Car Transport
Vehicle Car Transport Trailer Automotive exterior
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #15 · (Edited)
Finally got around to wiring up the camper shell's 3rd brake light and interior light.
Found the CHTL wire behind the spare/passenger side taped back to itself. I routed it through the nearby hole to keep it above the spare tire.
Used a 5foot 4-wire trailer extension that worked perfectly. Tied into the license plate light for the dome light.
Oh and it got it's first oil change.
Composite material Synthetic rubber Fuel line Tool Wire
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #18 ·
Got around to fixing the brakes. I found the RR brake was missing pin that holds the pad in and the springs, top washer retainer were backwards. 🤨
Fronts had stripped caliper bolts on the driver side. The top bolt was actually missing.
Picked up some oversized bolts $24ea.
Hopefully the holes aren't too wallowed out and these fix it.
Luckily the rotors are good.

Next on the list is O2 sensors then upper ball joints and tires.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #20 ·
The new caliper bolts worked great . That's a relief.
On the 02 sensors, I have an exhaust shop nearby my work I'll send it to.
A few months ago I had a accident changing leafsprings on my XJ and nearly busted my hand when the 3ft breaker bar slipped off. 😬
So when it comes to major seized bolt type of stuff, I'll have a pro do it.
Its way cheaper than a hospital bill and I need my hands to work.
Truck has been sitting for a few weeks so I'll drive it to work tomorrow.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #21 ·
Sent it to a shop to have the two (came with truck) 02 upper sensors replaced.
All was good for a few miles, then the light came on again. This time a new code PO154.
Took it back and he thinks it could be the ecm or other.
Note))) the lower 02's haven't been replaced yet, not sure how old they are.
He referred me to another diagnostic place that could get more in depth. Said it could be as simple as a broken wire or worse .
Hope I don't have to sell this truck.
Lets hear your input.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #28 · (Edited)
Today I swapped out the upper pass side o2 sensor and drove it, then I had bucking at light throttle then a few miles later the light came back on but drove great. PO132 . I cleared it and drove home, didn't come back on yet.

Im guessing the new sensors the previous owner gave me were wrong cause it looked different than the one I put in.
Pic is the one I pulled out, looks skinnier.
3036


Looks like cheap Amazon parts after looking up the part numbers.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #30 ·
It's been a few days and so far no light.

Pic::;;New sensor at the bottom (cap next to) .

Maybe now I can start fixing the upholstery, since it's what I do for a living.
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #31 · (Edited)
Well no codes till this morning. The annoying evap code po455.
My wife's Liberty gets this every once in awhile. Cleared it.

Went to Napa and picked up some upper ball joints. There's a choice of $33, $89, $103. Stayed away from the cheapies and got the $89 units. Guy said they were good on his Durango.

Also pulling the driver's rear seat bottom to replace a panel (cigarette burn).

Parked my XJ next to the truck, they are both the same height and my XJ is lifted 3" . 😎
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #32 ·
Pics of the seats.
1.) Rear seat bottom burn on the side. Panel will be replaced. Already have material.
2.) Passenger side bottom cigarette burn. I can "burry it" in the seam. Sewing the seam in more will fix that.
3.) Drivers side needs some foam repair.
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #37 ·
Great video. That kid sure is entertaining.
I'll be under the Dakota tonight where it's nice and peaceful. 😄
 
1 - 20 of 40 Posts
Top