Dakota Forumz banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I bought my '98 dakota about a year ago. When I first bought I had a whole slew of problems and had to replace pretty much the whole cooling system. I also replaced the alternator and the engine belt and since then I have never been able to get rid of this squealing noise that it makes if I turn on the A/C right when I start the truck. It also makes the noise after the truck has been running when I clutch the engine or take it out of gear. It seems like the A/C takes too long to cool down the inside of the truck because it doesn't get REALLY cold. At first I thought the noise was caused by the belt being to loose, or because it was new, but now I think it must have something to do with the A/C compressor. Has anyone else had this problem or know something I could try to fix it?
 

·
Aww Peg!
Joined
·
2,957 Posts
Welcome to the Z from NC! Sorry, can't help with your issue. Maybe one of the other members can. Glad you joined us, enjoy!
 

·
Registered
Joined
·
1,567 Posts
Welcome to the Z Family from Southern Georgia!
Glad you decided to join us.

When your truck is idling(A/C on or off), does the A/C compressor or its pulley also make unusual noises (think rattling or clunking)? I only ask because the bearing in mine went bad this past weekend and burned my serpentine belt. It was exhibiting the same symtoms you mentioned along with the noises I described. If that is the case, I'd take a good look at it before it gets worse or fails like mine did.
 

·
Registered
Joined
·
1,211 Posts
Welcome!

definitely check the pulley on the compressor, mine acts weird from time to time as well

let us know what you find out!
 
1 - 5 of 5 Posts
Top