Dakota Forumz banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi off grid here in white mountains truck is a 2006 4.7 dakota SLT magnum 139,000 miles dead reliable just recently been having an engine light come on checked fuel cap and evap hoses from what i learned on previous Dakota but all good tried the 3 key on method but cannot get any codes starts and runs fine any ideas , thanks
 

·
Registered
Joined
·
96 Posts
I am not an expert on this stuff, but it sounds like you are going to have to check it with a scanner & go from there.
 

·
Registered
Joined
·
725 Posts
The key trick does not work on out trucks, you'll need to connect an OBDII scanner to get the code, and find the cause. It could simply be one of your O2 sensors has gone bad, but who knows without the code.

Welcome aboard.
 

·
Registered
Joined
·
4 Posts
I have an '07 Dakota 3.7, basic truck with 1-1/2 dr with same issue. Took it to Auto Zone & O'Rileys both for free scan, and both said gas cap. Tried 2 separate after market caps over a few years of emission tests (owned since '13), and last time took it in for trans service & they replaced with OEM cap. Still throws code. They have a "smoke" system the evap is checked with, and went through it twice....still throws code and no leak results when tested. Price from $69-?? depends where you have it done, but all the same test. Local shop out in AJ East Valley, they said they would check it for me, and probably replace a couple hoses that are typical fails, but do not always show up. I looked at some youtube videos and seems easy enough to get to them, so will replace hoses myself and then clear codes to see how long check light stays off. If it pops again, replace a couple more. I think there are like 6 or so separate hoses, mostly around fuel tank, and under bed. Grandsons only out every few weeks and like to help so gives them something to do with Gpa :)
 
1 - 6 of 6 Posts
Top