Dakota Forumz banner
1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
We have a 2005 Dakota SLT and have owned it since 2008. It's been a good truck. But in 2021 things started going bad, and after spending time at four different repair garages (including a Dodge dealer) over the last year, but we still don't have a properly functioning truck. So here's our story, maybe someone has had a similar experience.

The problem that we have (and have had) has to do with a lack of power between 2000 rpm and 2500 rpm, particularly after the truck is warmed up. If you need to accelerate hard, like trying to enter a freeway, or leaving a traffic light, it doesn't go. And if you're trying to climb a short hill, she makes it, but the cars stuck behind you are very unhappy! You literally have to floor the accelerator and over-rev the engine to 4000-5000 rpms to make it go. It will get up to highway speeds if you feather the accelerator, but it is annoying. Presently, there hasn't been any trouble codes since the last ECM/PCM replacement (60 days ago). The list of what's been replaced is extensive. Remanufactured transmission (5/2021), remanufactured engine, long block, (9/2021) and replaced 2nd time under warranty 90 days later, ECM/PCM three times, O2 sensors, fuel pump, catalytic converter, muffler and resonator have been by-passed, intake manifold and injectors haven't been replaced but supposedly check out OK. That's the quick list.

In fairness to the truck, the transmission replacement was not due to this acceleration problem. The tranny just died. And in fact, the first long block replacement was not due to the acceleration problem, but it had been using oil crazy, like four quarts over 3 months for a few years. But as our "second car", we thought that pretty excessive so we had the engine replaced rather than pursue main seals or whatever. This acceleration problem didn't really fully manifest itself until after the first engine replacement. It's been game on ever since.

We would love to operate this 2005 another 15 years, but after approximately $16K in repairs, it might be time to move on. I will be happy to provide additional info, if someone can think of something that the other mechanics haven't considered or tried. Thank you and God bless.
 

·
Registered
2003 Dakota Sport, club cab, 3.9L V6, 5 speed manual
Joined
·
986 Posts
If you've had it to four shops and they haven't been able to correct it, I can certainly appreciate your frustration.

Has the weight increased significantly concurrent with the perceived lack of power -- such as the addition of a topper, loaded tool box, etc.? From what you've described, any lack of power from the engine has been addressed with the replacement of the engine (twice), redoing the exhaust system, transmission, and everything else. And I would suspect if there were any additional drag from brakes or suspension problems, they would certainly have shown up with handling or riding issues.

The 3.7L engine is more powerful than the 3.9L engine in my 2003 Dakota, but I don't have the issues you describe. However, mine has an empty bed 98% of the time. The powerband on the 3.7 is pretty steep. At 2000 rpm, it's developing only 75hp going to 100hp at 2500 rpm. At 4000 rpm, power is up to 175 hp and goes to 200 hp at 4500 rpm. These figures are for a 3.7L in a Jeep Liberty, see 3.7L HP/Torque curves.

I don't really have any other thoughts about what may be causing these issues. Good luck on getting it resolved!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thank you @oldmarine for your response. Unfortunately we haven't changed the weight in the truck, although I've gained about 10 pounds in the last year! Hoping something will click with someone. We can't possibly be the only people this community that have had this issue -- or could we?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
I read at another dodge dakota forum about power issues being due to a bad alternator. Which on the surface sounds crazy to me, but it's practically the only thing that we haven't replaced in this 2005. Anybody have any experiences with that and does it make any sense?
 

·
Registered
Joined
·
2 Posts
I read at another dodge dakota forum about power issues being due to a bad alternator. Which on the surface sounds crazy to me, but it's practically the only thing that we haven't replaced in this 2005. Anybody have any experiences with that and does it make any sense?
I am no expert on Dakotas, but it sounds like you are not getting enough fuel into the engine. I have a 1997 and the only fuel filter is inside the tank, not sure about 2003. I assume you have checked fuel lines for air, a clogged return line and pressure. Have you replaced your fuel pump or looked at the screen or tank?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
@Scullet The fuel filter/screen and the fuel pump were replaced about 30 days ago. According to the mechanic there was pretty good fuel pressure before the replacement but it was worth a shot. (A Hail Mary I guess you call that.)
 

·
Registered
Joined
·
2 Posts
I would put the truck on a chassis dyno to get live data as to what is happening or not happening while in running conditions. With all you have had replaced something wasn't and is being moved with each repair. Also what tire size are you running my 2006 has two choices and i am running the bigger ones myself. I have noticed that going up hills i need to down shift more. A quick check for a clogged exhaust would be to cut the exhaust pipe after the cats in a straight spot to make it easier to put a coupling in line to join the two parts back together. My overall opinion is you don't have enough gear, a clogged exhaust after cats, or there is a sensor that is in parameters but not working properly for the vehicle.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
@Ricky J Our 2005 is running the larger tires and yes we too experience the increased down shifting. But it has been this way almost from Day 1 and it's not a big deal, we've learned to live with that. But what we're dealing with is definitely worse. We thought maybe a clogged exhaust too, supposedly the auto repair shop cut the exhaust pipe to bypass the muffler and resonator. No change from that. It it is a sensor as you suggest, how does one chase that down? It's managed to evade detection by four shops.
 

·
Registered
Joined
·
63 Posts
Kind of a long shot, but its cheap and easy. Run some fuel injector cleaner through it, if the injectors havent been replaced, they may be dirty or slightly gummed up. I mean hell it wouldnt hurt at this point.
 
1 - 9 of 9 Posts
Top