Dakota Forumz banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Got a front damaged '95 4x4 x-cab, 3.9 V-6, automatic that is a clean survivor (115K and no rust in Michigan too). I plan on swapping out parts from another parts truck ('96 similar but 2wd), core support looks like a bolt on swap and needed. I noticed that P ('park') doesn't seem to engage or work and start up in neutral is ok (might be linkage bent have not looked yet or worse?). Starts and runs and moves, that is the good. The bad is it seems to come out of selector for 4x4- high-low or 2wd (might also be linkage related damages????). Left front wheel is closer to wheel well/ fender, frame seems ok, so is it most likely bent control arm(s), I guess I can do measurements soon and figure that out. Also, front clutch fan for cooling is bent and even the power steering pump and pulleys must be bent some, as belt is damaged some, but does run and work otherwise. I presume switching the clutch fan, water pump, power steering bracket and related pulleys....likely will fix all that to the normal positions.

Like the truck and plan on fixing it all, any feed back on what I might be dealing with or concerns or red flags to know about would be good. I am not up on the 4x4 stuff and never owned a Dakota prior. Used to work on a lot of 1990's front drive dodges and caravans, used to them. I am all ears here on out.........:)
 

·
Banned
Joined
·
2,418 Posts
Hello and welcome!

Good to have you with us, I hope you enjoy the board! :)
Engine questions I would ask here
Suspension here

Reason why is not everyone comes in here and asking out in the topic appropriate sub forums will get you the right people looking! :)
 
1 - 3 of 3 Posts
Top