Dakota Forumz banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey there, had a few dodge trucks in my years, currently driving a modest Dakota SXT with a 3.9 V6. Good running truck and great to drive. Recently on two occasions it threw a 0432 code saying the cat on bank 2 was not up to specification and about the same time, it started to act up. It starts fine and seems to run well when given throttle but when you lift of throttle, it dies rather than return to idle. I am old school and don't know much about this injection or computer stuff so looking for some wisdom out here on the net. Any ideas.

Carl in Riverview
 

·
Registered
Joined
·
1,567 Posts
Welcome to the Z Family from Southern Georgia!
 

·
Registered
Joined
·
842 Posts
Hey Carl, welcome from Western Central Arkansas! So, how close are we, in age (Seeing as how I'M also an OLDER Mopar Fanatic)? I really don't know what to tell you, about your problem. RamTech seems to have an upper had, when it comes to the knowledge on these things. Some others might have some insight as well. I'm so NOT INTO This type of engine controls that I'm putting an OLD SCHOOL 440 in my '92 Dakota (NO Fuel Injection and NO Computer). ;)
 

·
Registered
Joined
·
1,211 Posts
Welcome Carl! someone on here posted a similar issue with their 5.2l where it would die when letting off the gas pedal

i suggested to check the TV (throttle valve) cable. i think it works by telling the transmission that you have let off the gas and to downshift or idle, but my thinking is that if it come loose or slid out of place it could cause the car to stall. kind of the way on a manual if you slow down too much without pushing in the clutch

hope that helps
 
1 - 5 of 5 Posts
Top