Dakota Forumz banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1992 Dakota v8 4x4 with automatic overdrive transmission. Recently it felt sluggish taking off from a stop as if it was stuck in 3rd. I replaced the "Transmission control solenoid" (https://shop.advanceautoparts.com/p...olenoid-s39050/18260311-P?searchTerm=solenoid) and all of a sudden overdrive isn't working anymore. All fuses are okay.

Is there anything I could have messed up while under the truck to make overdrive quit working so suddenly? Any troubleshooting tips?

Should I replace the governor pressure solenoid?
 

·
Registered
Joined
·
294 Posts
losing OD on that trans is kind of common, could be anything from a spring broken on the valve body (not that hard to fix if you can change that solenoid)
to a defective new switch being it now seems different from before you changed it
to being burnt up and the clutches having welded themselves together (saw that on the most recent one I overhauled)
or the clutches and seals being "shot" in the rear section (can actually be removed with rest of trans still in truck)
do gears 1-2-3 and R work as they should?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
losing OD on that trans is kind of common, could be anything from a spring broken on the valve body (not that hard to fix if you can change that solenoid)
to a defective new switch being it now seems different from before you changed it
to being burnt up and the clutches having welded themselves together (saw that on the most recent one I overhauled)
or the clutches and seals being "shot" in the rear section (can actually be removed with rest of trans still in truck)
do gears 1-2-3 and R work as they should?
1,2,3 and R still work as they should. It's not going into OD whether the button is pressed or depressed. Before swapping that one part OD was still working. Could that one part be defective from autozone or could replacing the other solenoid possibly fix it?
 
1 - 3 of 3 Posts
Top