Dakota Forumz banner
1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hi all,
I have an 88 dakota 3.9 ,2wd,a/t.

When I let off the gas coming to a stop I'll get about a 100 to 200 rpm cycling a few times then it will settle down. I've changed the tops, fuel pressure regulator, checked what vacuum lines I could and everything seems to be airtight. I DID smoke test the vacuum system and the bottom butterfly shaft has a small leak. I've taken apart my idle solenoid and greased everything. But you can see it pulsing when I do a quick rev and release. Any ideas?


Thanks for the help
 

·
Registered
2003 RT (5.9)
Joined
·
757 Posts
Here is a thread/topic that MIGHT be applicable and that you might find interesting.


Basically it discusses a idle "hunting" condition caused by a vacuum leak which often originates from the intake plenum gasket leaking (which, I understand, the 3.9/5.2/5.9s are famous for).

Bottom line seems to be that if you look down the throat of your TB & note oil pooled up on the bottom of your intake, the plenum gasket is the culprit.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Here is a thread/topic that MIGHT be applicable and that you might find interesting.


Basically it discusses a idle "hunting" condition caused by a vacuum leak which often originates from the intake plenum gasket leaking (which, I understand, the 3.9/5.2/5.9s are famous for).

Bottom line seems to be that if you look down the throat of your TB & note oil pooled up on the bottom of your intake, the plenum gasket is the culprit.
Found the issue, thanks everyone...pinhole in MAP sensor vacuum line.
 
1 - 5 of 5 Posts
Top