Dakota Forumz banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
i bought a 93 dakota sport with a 3.9 from a friend last week. its got 92k on it and runs well. my friend only bought it because it was his boss's, who passed away, it was in great shape and he got it cheap. he didnt drive it at all, since he didnt really need it. it sat for about a year and a half. he knew the boss was having problems, before he got it, with it not shifting into overdrive and stalling when you stop, but never got around to figuring out why. the first thing i did was replace the TPS and the IAC motor. i thought that would solve both issues, but it didnt seem to make a difference. My next course of action is to replace the OD solenoid, but thats not gonna be for a couple of weeks for financial reasons. i still don't know why it stalls. it runs really nice and idles smooth, and also shifts 1-3 nicely. am i on the right track? or am i missing something. thanks in advance for any suggestions you guys have.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
no lights. all the gauges read good. no sign of any problem, other than fact its turning 3000 rpm at 65 miles per hour. 1-3, up and down shift nice so i dont believe there are any problems with the tranny itself, at least hydraulically. my chrysler tech knowledge during this period, 90's-now is pretty hazy. 60's-70's mopar i am much more at home with. i have done some work on my 99 navigator and know there is a diagnostic that you can run on the tranny/transfer case and it will flash codes with the OD light. is there anything like that with a 93 dakota? i realize the nav is OBD/II and dakota is OBD/I so there is light years between the computers, but that type of diagnostic would be helpful here. thanks
 
1 - 3 of 3 Posts
Top