Dakota Forumz banner
1 - 5 of 5 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
So I have a 2001 4.7 4x4 83000 miles automatic trans.
So I took it to my oil change shop and wanted my tranny flushed cuz I just bought it.. They said they "pulled the line and no fluid was being pumped" he thought my tranny pump was out. I thought it was interesting because it drives and shifts like a champ not slipping or rough shifts NO PROBLEMS. So I took if to AAMCO and the guy said I was gonna cost 2500 to rebuild the tyranny... U explained I had no problems and he said "you will " so I took it to a smaller shop and told him everything and he said " if the pump was bad you would know it!" He told me if its acting fine then he might have done something wrong and the oil change shop! He told me to drive it across town and if I don't burn it up then it's fine... Drove it across town with no probs... What do I do?
 

·
Banned
Joined
·
2,418 Posts
Hello and welcome!

Good to have you with us, I hope you enjoy the board! :)
You might try posting your question here where the more mechanical minded people will see it and better your chances for an answer.
 

·
Registered
Joined
·
141 Posts
allot or mechanics will say, Never bother changing tranny fluid, the sludge is bonding and keeping stuff actually working in there, lot of speculation that once you open it up thwe tranny ( rear ends too ) it opens up a can of worms !
 

·
Registered
Joined
·
141 Posts
thats good to ! we had a thread on this at challengerforumz. and a few mechanics chimed in. they were mentioning this. I was taught this too . !! no biggie ! who knows, could be the best for it too !!
 
1 - 5 of 5 Posts
Top