Dakota Forumz banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Just installed rebuilt transfer case on my 4.7 (Np 233),(Case was initially cracked in 3 places and was leaking) as of now no 4 wheel drive, checked and rechecked connections on transfer case. When i initially start truck; my drive mode indicator lights all illuminate,(switch on dash) then all go out. 10 secs later service 4 wheel light comes on, cant shift into 4 wheel, i can't figure out what the culprit is? tccm; the sensor on side of transfer case, or the motor on transfer case, or even how to isolate problem,:confused: any help would be good
 

·
Registered
Joined
·
250 Posts
Start by getting the modules scanned and find out what the codes are. Once we have those, we can narrow it down.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
took it to tech today was diagnosed as TCCM now my fun begins, where is it? which one is it?(need a code off box), is it plug and play?
 

·
Registered
Joined
·
250 Posts
It's located behind the center section of the lower instrument panel, to the right of the steering column. If I recall correctly, it should be plug and play for that year but I'm not 100% certain.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 · (Edited)
yes dealer said it's plug and play, waiting for delivery of "used One", got it at fraction of a new one, we'll see how it goes, more tomorrow, i needed to detail dash board anyways lol, Oh and for anyone who needs one here's some helpful info , the part number of tccm to help finding right one is.. 1st off 2001 thru 2004 are interchangeable a 2002 is P56028242A(F) a 2003 would be (G) a 2004 would be (H) an 05 would be (I) ...when ya call a boneyard about one they ask for code off side of tccm, helped me cause if they aint got it the dealer has to order it and we all know how long that takes, hope this helps someone it helped me
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Well good news after putting in New '03 TCCM in my 02, the service 4 wheel drive light was still on drove to dealer and they tried to clear codes, he told me bad shift motor "OUCH" so i ordered a new one, then 2 hrs later after driving some..The damn indicator lights came on and 4 wheel started working again, the tech did tell me that sometimes the computers learn, after so many regular starts. Damndest thing but it's all good now :)
 
1 - 7 of 7 Posts
Top