Dakota Forumz banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all,

I have a 2006 Dodge Dakota 4x4 quad cab with just over 80,000 miles on it. About 7 months ago the transmission temperature light started coming on at what seemed random times while driving, both highway and in town. I brought it to a dealership and they held it for two days, charging me $100 and putting 200 miles on it and saying that they couldn't do anything about it because the light never came on for them. The mechanic told me it was either electrical, in which case not to worry immediately, or that it was a transmission issue which would cost an arm and a leg. I wasn't too worried about it because he told me unless I feel it "slipping" while the light is on it was probably just electrical. Well 7 months later the light is still coming on, still seems to be random, however it is occurring more often and now it does feel like the transmission is slipping while shifting.

Any knowledge, input or experience with this issue would be greatly appreciated. Thank you all.
 

·
Registered
Joined
·
1 Posts
I have an 05 Dakota and have had the same issue. I had the transmission serviced last year, at which point it quit for a few months, then started to come back on. Talking to a couple of different mechanics, I learned that the transmission temp is measured by VOLTAGE, not actual temperature. Basically, I was told if the transmission isn't acting up just to ignore it.
 
1 - 2 of 2 Posts
Top