Dakota Forumz banner
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have been working on my truck recently, and just finished replacing the engine (not relevant to this post), and I went to try out the different functions, and my turn signals do not seem to be working. If I click the knob to turn on the right signal, it will make the clicking sound, without lights for a few seconds, then the lights will come on. If I click the knob to the left turn signal, then it will not work until I jostle the stick a little bit. what is the best thing i can do? Should I pull it apart and try to fix it myself, or should I just buy a new turn signal switch? If there is anything else that i may do to fix this without tearing the steering wheel apart, i would enjoy suggestions for that too.
 

·
Registered
Joined
·
1,567 Posts
Unfortunately, this is not my area of expertise. Hopefully someone will be around soon that can help. Good luck!
 

·
Registered
Joined
·
830 Posts
my turn signals do not seem to be working. If I click the knob to turn on the right signal, it will make the clicking sound, without lights for a few seconds, then the lights will come on.
I assume here, that the turn signals worked properly BEFORE you did
all that engine work? If you hear the clicking sound, that is the flasher relay operating.


If I click the knob to the left turn signal, then it will not work until I jostle the stick a little bit.
You must mean jiggling the turn signal stalk which has the multifunction switch
for dimming the headlights, wiper/wiper delay and turn signals?
It could have an intermittent contact in the flasher relay.
Asumming here that have been no wiring changes as a result of the engine work.
I would try to replace the flasher relay first as that is a simple and inexpensive part.

what is the best thing i can do? Should I pull it apart and try to fix it myself, or should I just buy a new turn signal switch?
That is a very expensive dealer part. You should try to troubleshoot the problem first, if you can.

The headlight/flash portion of the multifunction switch is separate from
the turnsignals. So is the wiper/wiper delay function, and that makes it a very expensive dealer part
unfortunately.

The multi-function switch (turn signal stalk) gets it 12v from the PDC,
through a 20 amp fuse, which ALSO provides power to:
1) stop lamp switch
2) aftermarket accessories
3) center high brake light

The turn signal function is combined with the hazard switch, which
will turn on the combo flasher (hazard/turn signal) relay located on the
side panel of the dash. (If the hazard button is not depressed, the turn
signal stalk signal switch will operate the flasher relay and route the
interrupted 12v from the flasher to the appropriate set of signal lights
LR/LF and RR/RF. )

The output of the turn signal portion of the multi-function switch, goes to the appropriate selected
turn signal bulb, (which is a dual filament), combination brake/signal and parking light.


If there is anything else that i may do to fix this without tearing the steering wheel apart, i would enjoy suggestions for that too.
I think you should try and troubleshoot it first with a digital voltmeter to see where the problem is before substituting
a very expensive part and going through all the labour of replacing it. Replace the flasher relay first, make sure all
the turn signal bulbs have clean and rust free sockets, as a BAD ground in a socket could cause this kind of weak
signal light function..or a burned out bulb filament.
 

·
Registered
Joined
·
1,211 Posts
thanks for that great reply caverman, hopefully some of that will help, reps to you!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 · (Edited)
@carverman

the hazard lights/switch work just fine, i do not know if the turn signals had been working before replacing the engine, i had bought it from somebody and the battery was dead, and *he had said that it was blowing smoke and already had a new engine, so i replaced it* (*has no relevance to electrical). anyway, all of the turn signal lights work, but the stalk doesn't work properly.
i'll take your suggestion and try diagnosing it with a voltmeter, but i hope i don't have to try finding this at a dealership, since i was looking for parts for my carburetor there, and they didn't carry them, and i also hope i don't have to go by a junkyard and tear one of these out of one of the cars there to get a working one, since that would be a pain in the ass for me since i live in Arizona.
 
1 - 6 of 6 Posts
Top