Dakota Forumz banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 1996 Dakota with the V6 and throttle body fuel injection. The unit has started having a no idle condition after it warms up recently. I've used injector cleaner which at first acted like it made a difference but really it hasn't. This is not consistent, sometimes it will run fine all day and the next day it won't idle after shutting it down and restarting it. It seems to idle just fine until after the first shutdown after warming up. I'm guessing there is a bad sensor or module there somewhere but don't know where to look. It doesn't matter what the weather is, it can have this problem in the heat of the summer or cold of winter. Like I said, one day it's fine and the next no idle then turn around and be fine again a day later.
Any ideas?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I've put injector cleaner through the tank several times. That's about it so far. Forgive my ignorance but what is IAC?
 

·
Registered
Joined
·
1,211 Posts
IAC=idle air control, it controls the air through the throttle body at idle. cheap at rockauto.com if you want to replace it, $23-$56

not sure how to clean it though or if injector cleaner did the trick
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
IAC, that sounds like a good place to start. I don't think it is the throttle body because it runs perfectly at times and you shut it off and restart and it doesn't. Thanks for the tip.
 

·
Registered
Joined
·
1,211 Posts
you're welcome, let us know what works
 
1 - 6 of 6 Posts
Top